+3 votes
in Operating Systems by (4.5k points)

When I ran "yum -y update" to update packages, it updated all but initscripts.x86_64.

I got the following error message: initscripts.x86_64 0:9.49.47-1.el7 failed to install.

How can I fix this error?

1 Answer

0 votes
by (20k points)

To fix this error, run the following command as root.

chattr -i /usr/lib/udev/rules.d/60-net.rules

 File "60-net.rules" is immutable, so you are getting the error. chattr -i will clear the immutable attribute of the file and then it can be modified.

After running the above command, run

yum -y update

to update all packages.

...