+2 votes
in Programming Languages by (4.3k points)

I am installing the python package "allennlp==0.9.0" on the Debian system, but it fails and gives the following error:

  error: invalid command 'bdist_wheel'

    ----------------------------------------

  Failed building wheel for sentencepiece

  Running setup.py clean for sentencepiece

Failed to build sentencepiece

How can I fix this error? 

1 Answer

0 votes
by (31.4k points)

Try one of the following approaches and it should fix the error:

1. Upgrade pip version and then install the package "allennlp".

sudo pip3 install --user --upgrade pip

2. If upgrading pip does not solve the problem, install the package "sentencepiece".

sudo pip3 install sentencepiece

...