+1 vote
in Programming Languages by (8.7k points)
recategorized by

While installing tensorflow, I am getting the following error:

ERROR: tensorboard 2.0.0 has requirement setuptools>=41.0.0, but you'll have setuptools 39.0.1 which is incompatible.

How can I upgrade setuptools?

1 Answer

0 votes
by (17k points)

To upgrade setuptools, try one of the following two options:

Option 1:

First uninstall and then install the newer version

  • pip3 uninstall -y setuptools
  • pip3 install setuptools>=41.0.0

Option 2:

pip3 install --upgrade setuptools

...