+2 votes
in General by (11k points)
I have installed pycharm community and android studio on my Ubuntu 14.04 machine, but I am getting warning message - IBus prior to 1.5.11 may cause input problems. How can I fix/ ugrade ibus error?

1 Answer

0 votes
by (11k points)
edited by

1. Download the following .deb files from https://launchpad.net/~tista/+archive/ubuntu/wayland/+build/8927526 to any folder.

gir1.2-ibus-1.0_1.5.12+git20160201-0ubuntu1-xenial1_amd64.deb
ibus_1.5.12+git20160201-0ubuntu1-xenial1_amd64.deb
ibus-gtk3_1.5.12+git20160201-0ubuntu1-xenial1_amd64.deb
ibus-gtk_1.5.12+git20160201-0ubuntu1-xenial1_amd64.deb
libibus-1.0-5_1.5.12+git20160201-0ubuntu1-xenial1_amd64.deb

2. cd to that folder where you downloaded the above files.

3. run the command 'sudo dpkg -i *.deb' on terminal .

4. run the command 'sudo apt-get install -f' on terminal.

Hopefully these 4 steps should solve the issue. At the time of writing this answer the version of ibus is 1.5.12. If you find newer versions, you might try.

Second approach: if you get any dipendency issue, follow the 2nd approach mentioned below.

if you use only one keyboard layout you can go to : System Settings ­> Language Support and change Keyboard input method at the bottom of the page from ibus to none.

...