+1 vote
in Programming Languages by (45.3k points)

I am using the conda environment to run my python codes. One of my codes that uses the scipy library is throwing the following error:

ImportError: /home/user/miniconda3/lib/python3.10/site-packages/scipy/sparse/../../../../libstdc++.so.6: version `GLIBCXX_3.4.30' not found (required by /home/user/miniconda3/lib/python3.10/site-packages/scipy/fft/_pocketfft/pypocketfft.cpython-310-x86_64-linux-gnu.so)

How can I fix it?

1 Answer

+1 vote
by (176k points)
selected by
 
Best answer

It seems that scipy has some issues with the version of gcc on your machine. Try to install the latest version of gcc using the following command on the terminal. Hopefully, it should fix the error.

conda install -c conda-forge gcc

If the above command does not solve the issue, try to update scipy too. 

conda install -c anaconda scipy

Related questions

+1 vote
1 answer
asked Sep 20, 2022 in Programming Languages by kush (35.2k points)
+3 votes
1 answer
+2 votes
1 answer

...